Salut tout le monde, je viens d’avoir un petit problème en essayant de mettre à jour mon archlinux ce matin; Fixons ça en 2 minutes!

Premièrement ce problème apparaitra seuelement si vous avez activé le support multilib d’archlinux (https://wiki.archlinux.org/index.php/multilib). Pour fixer ce problème vous devez installer tous les paquets gcc en multilib ou aucun, mais pas les deux. Premièrement, trouvons quels paquets foutent le bordel. Utilisez :

1
sudo pacman -Qs gcc

Vous devriez avoir un output comme ça :

1
2
3
4
5
6
7
8
local/gcc 6.3.1-2 (base-devel)
  The GNU Compiler Collection - C and C++ frontends
local/gcc-libs-multilib 6.3.1-2
  Runtime libraries shipped by GCC for multilib
local/lib32-gcc-libs 6.3.1-2
  Runtime libraries shipped by GCC (32-bit)
local/libgsystem 2015.2+4+gd606be
  "Copylib" for system service modules using GLib with GCC

Dans mon cas on peut voir que gcc lui-même ne supporte pas multilib. Installons la version multilib.

1
pacman -S gcc-multilib

Et voilà! Problème résolu :) 2ez